客服电话
400-820-3678

客服QQ
4008203678

关注我们
认准客服信息
其他均为仿冒

 非凡VPN 改版啦

非凡VPN的官方网站自从2010年第二次改版至今,一直维持古朴的风格。 为了让非凡VPN官网美观易用,我们于2016年8月正式启用非凡VPN网站的第三版,欢迎反馈意见建议。

非凡VPN官方联系方法:
客服电话:400-820-3678
客服QQ:4008203678

非凡VPN为您提供最优质的VPN服务:
Windows,Mac OS X,Android,iOS全平VPN客户端 »
目前拥有遍布5大洲的300多台VPN服务器 »
免费试用,满意再买 »

我知道了

好用的VPN客户端

支持 Windows,Mac OS X,Android,iPhone/iPad,Linux 等平台

一键安装,操作简便,功能强大

非凡VPN Linux 客户端

非凡VPN Linux 客户端下载 非凡VPN Linux 客户端下载
操作系统 内核 >= 2.6,所有主流发行版/OpenWRT/DD-WRT
软件版本 3.7.1.2
文件大小 1.1M - 1.6M
发布日期 2017-01-11
PC系统:x86 (32-bit, 64-bit)
嵌入式系统: armel mips mipsel
x86/armel/mips已经测试可用。mipsel未测试。如有问题请反馈给我们。

注意:OpenWRT/DD-WRT版仅供高端玩家研究,连接成功后通常还需要一些额外配置工作,我们暂时没办法提供所有场景下的支持,需要您自己发掘。

使用帮助

# wget THE-DOWNLOAD-URL

# tar -zxvf THE-DOWNLOADED-TAR-GZ

# vim /etc/ffvpn.conf
user YOUR-ACCOUNT-NAME
pass YOUR-PASSWORD

# ./ffvpn login
ffvpn 3.6.0.2 (core:160814-1519)
Load config file: /etc/ffvpn.conf
Command: login
Logging in ...
Login done.
=====================================================
Web Site: https://www.ffvpn.com/
Login Result: OK
Expiration: Sat Jul 22 23:53:39 2017
=====================================================

查看所有可用服务器:
# ./ffvpn list

查看美国服务器:
# ./ffvpn list "usa"

ffvpn 3.6.0.2 (core:160814-1519)
Load config file: /etc/ffvpn.conf
Command: list
      11	California 04 (Fremont,28IP)
      50	Oregon 02 (Portland,5IPs)
      57	Relay to USA 12 (Shanghai Telecom Relay To USA 12)
      77	Nevada 01 (Las Vegas,7IP)
      90	Relay to USA 13 (Shanghai Telecom Relay To USA 13)
      91	Georgia 01 (Atlanta)
      92	Relay to USA 14 (Shanghai Telecom Relay To USA 14)
      95	Relay to USA 15 (Shanghai Telecom Relay To USA 15)
     105	Relay to USA 16 (Shanghai Telecom Relay To USA 16)
     106	Relay to USA 11 (Shanghai Telecom Relay To USA 11)
     109	USA 13 (Los Angeles;5IP)
     123	Illinois 01 (Chicago,5IP)
     143	New York 01 (Long Island Via HK;3IP)
....


# ./ffvpn connect "California 04"
ffvpn 3.6.0.2 (core:160814-1519)
Load config file: /etc/ffvpn.conf
Command: connect
=====================================================
Web Site: https://www.ffvpn.com/
Login Result: OK
Expiration: Sat Jul 22 23:53:39 2017
=====================================================
Server: "California 04"
Please choose protocol [udp/tcp/lwip/socks5]: udp
2016-08-14 16:58:40 [I] ffvpn state = 102, rx = 608, tx = 1776
2016-08-14 16:58:40 [I] ffvpn state = 200, rx = 861, tx = 3132
2016-08-14 16:58:40 [I] ffvpn protocol: udp
2016-08-14 16:58:41 [I] ffvpn opened tun: tun0
2016-08-14 16:58:41 [I] ffvpn setting ip addresses and routes ...
2016-08-14 16:58:42 [I] ffvpn server: California 04, server virtual ip: 10.253.250.1
2016-08-14 16:58:42 [I] ffvpn tun: tun0
2016-08-14 16:58:42 [I] ffvpn dns: 8.8.8.8,8.8.4.4
2016-08-14 16:58:42 [I] ffvpn use vpn as default route gateway
2016-08-14 16:58:42 [I] ffvpn backup dns /etc/resolv.conf to /tmp/ffvpn-resolv.conf.backup
2016-08-14 16:58:42 [I] ffvpn update dns nameserver in /etc/resolv.conf
2016-08-14 16:58:42 [I] ffvpn done
^C
Signal: 2, stop & exit
2016-08-14 17:02:57 [I] ffvpn restore dns /etc/resolv.conf from /tmp/ffvpn-resolv.conf.backup
2016-08-14 17:02:58 [I] ffvpn state = 0, rx = 12170284, tx = 5971328
2016-08-14 17:02:58 [I] ffvpn stopped.

# ./ffvpn --help
show help for expert users: more options, up/down script, etc.

    

OpenWRT 教程

固定配置(只需要设置一次,永久保留即可)
# opkg update; opkg install ip kmod-tun

# vim /etc/config/network
在文件末尾增加如下内容:
config interface 'vpnnet'
        option ifname 'tun0'
        option defaultroute '0'
        option peerdns '0'
        option proto 'none'


# vim /etc/config/firewall
在文件末尾增加如下内容:
config zone
        option name vpnzone
        option input ACCEPT
        option output ACCEPT
        option forward ACCEPT
        option masq 1
        option network vpnnet

config forwarding
        option src vpnzone
        option dest lan

config forwarding
        option src lan
        option dest vpnzone

# /etc/init.d/network reload
# /etc/init.d/firewall reload
动态配置(每次都可以按需配置,重启后可能会失效,断开后建议恢复dns配置)
# vim /tmp/resolv.conf.vpn
nameserver 8.8.8.8
nameserver 8.8.4.4

# vim /etc/config/dhcp
把默认的dns配置选项
        option resolvfile '/tmp/resolv.conf.auto'
替换为
        option resolvfile '/tmp/resolv.conf.vpn'
(断开后记得把这个配置恢复并重启 dnsmasq)

# /etc/init.d/dnsmasq restart
然后按照正常步骤,使用客户端程序登录并连接。现在所有用这个路由器的计算机都可以通过vpn访问网络了!
开源许可协议: lwIP libevent zlib curl mbedtls

版本历史